Discovery Sport Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
Hi all. I filled up my wiper washer fluid today and found that it is leaking if I fill it past a certain point. It is not full. I tried to get a good look at the bottle but it is buried in behind the front bumper. I think it is either cracked/split or a hose is not attached properly. Has anyone else experienced this? Any ideas?
 

·
Super Moderator
Joined
·
510 Posts
I had a leak in mine years ago , but it was the hose that went to the headlight washing spray head.
 

·
Registered
Joined
·
50 Posts
If you wanted to inspect it yourself, it’s a bumper-off process unfortunately. Here’s what my reservoir looks like. The neck of the plastic tube does look like a weak spot.
7588
 

·
Registered
Joined
·
30 Posts
Discussion Starter #4
Thanks for the advice. Great photo by the way. Thank you. Its filling up to a certain point and then leaking out. Judging by how much water trickles out I feel it’s at the point where the filler neck joins the tank. Is it a huge task to remove the bumper? How long would it take?
 

·
Super Moderator
Joined
·
510 Posts
I would just fill the tank part way until there was a time that the bumper had to come off for some other reason.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #6
I would just fill the tank part way until there was a time that the bumper had to come off for some other reason.
Looks like the front washer jets aren’t working now but the rear one is working. Weird as they run from the same tank. Might be taking the bumper off....
 

·
Registered
Joined
·
30 Posts
Discussion Starter #8
Thanks Bill.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #10
So yesterday the car went into restricted performance mode while I was driving home along the highway so I took it to the local LR service centre and asked them to have a look at the wiper washers while it was there. They removed the inner wheel arch guard and found the washer hose for both front and rear screens were split and require replacing. $30 part, $300 labour 🙄. Diagram below showing parts required just as an FYI.
0E9F8399-244A-4F99-9E75-2FBF3AFDA445.jpeg
 

·
Registered
Joined
·
30 Posts
Discussion Starter #11
Update. I called LR customer service and they offered to help out by reducing the price of this repair considerably. Parts arrived in 3 days and it’s all fixed now. Happy with the outcome.
 

·
Registered
Joined
·
30 Posts
Discussion Starter #13
So yesterday the car went into restricted performance mode while I was driving home along the highway so I took it to the local LR service centre and asked them to have a look at the wiper washers while it was there. They removed the inner wheel arch guard and found the washer hose for both front and rear screens were split and require replacing. $30 part, $300 labour 🙄. Diagram below showing parts required just as an FYI.
View attachment 7618
Sounds great, but what about the restricted performance?
Hi Bill. I have a separate post on this. Read it here: Restricted performance
 
1 - 14 of 14 Posts
Top