Discovery Sport Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
as soon as I go over 100km/h / 60mph I start feeling vibrations through the whole car?!

as if I would be driving on MT terrain tires with big threads, but I don't!

it has been back in the shop, they changed front tires, all does not help

my wif has an Evogue, same tech, but no vibrations like me

car has been balanced and outlined, nothing seems to work

has anyone have any idea? please?!
 

·
Registered
Joined
·
588 Posts
Assuming you are using the factory stock wheels and tires - the issue you are having seems to point at the balance or suspension area.

I have seen more issues with aftermarket wheels and tires causing vibration issues...

If the factory tires and wheels have been ruled out, then the next step is to have the dealer check out the suspension, control arms and cross members.

There is an alert out for certain Discovery Sport with a control arm/steering issue that may be your issue:
https://www.cars.com/articles/recall-alert-2016-2017-land-rover-discovery-sport-range-rover-evoque-1420692837840/

"Vehicles Affected: 220 model-year 2016-17 Land Rover Discovery Sport SUVs manufactured between May 30 and Aug. 24, 2016, and model-year 2016-17 Range Rover Evoque SUVs manufactured between June 7 and Aug. 26, 2016
The Problem: The front lower control-arm fasteners could fail, which may result in separation of the steering knuckle, negatively affecting vehicle handling and increasing the risk of a crash.
The Fix: Dealers will replace the hardware that connects the front lower control arm to the knuckle for free.
What Owners Should Do: Land Rover will begin notifying owners on Jan. 30.
 
1 - 3 of 3 Posts
Top