Discovery Sport Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
My 2018 LR Discovery Sport HSE has this vibration noise when moving up though the gears (auto) when under load. The noise is not replicated when revving the car in neutral? Have had DPF sensor pipe replaced, but no change. Have had fuel pipe clips tightened - no change. Have had heat shields checked out - no issues, albeit the bottom one fell off, but I was told by the dealership it was not needed - so meantime it is sitting in my garage. Anyone else had this issue and found the solution? it is driving me round the bend! I am sure I read somewhere that someone had found it was air con pipes somewhere? Any experiences/solutions?
 

·
Registered
Joined
·
15 Posts
You may have been on the right track with the clips. If you poke around looking for loose bolts or broken clips on everything, you may find what's come loose and is now allowed to rattle around. Might be worth checking the motor, transmission, and exhaust mounts too. If they've come loose and the engine is moving around more than it should, it can cause all kinds of rattles. I wouldn't go replacing parts at this stage unless you can see something has broken.
 

·
Registered
Joined
·
1 Posts
Hi there,iv just brought a 2017 LD ,I have a vibration noise when i sit at lights some times when my foot is on the break.Iv not got the auto stop on as it drives me mad ,could it be the clutch slipping ,dos any one else have this problem?
 
1 - 5 of 5 Posts
Top