Discovery Sport Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hello, just bought a 2016 on Saturday and we went to the beach today. Overall vehicle drives great but I was on a very modest hill sitting at a stop sign waiting to pull out on to A1A and when I removed my foot from the brake pedal and pressed on the accelerator nothing happened, the car just sat there revving and while I was deciphering what was going on it even rolled back slightly. There was no one behind us and I quickly applied the brakes and then tried to apply the throttle and still nothing. I then went to R and backed up a bit and then back to D and things worked as designed....did not experience this issue at any other time. Has anyone else heard of this? One other thing...on the way home I noticed that when driving stop and go that upon stopping there would be the normal pause followed by a distinct (to the driver) mechanical/hydraulic engagement of the transmission feeling. I'm taking her back to the dealer tomorrow...we also had the engine emissions service light go on.
 

·
Registered
Joined
·
588 Posts
Yes, it happened to me once.
On a hill, the car would not move - the D was flashing on the tranny selector.

Had to restart the car and it worked.....
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
The dealer updated the software in the transmission, but they were clearly concerned when I described the problem...I must say though that after the latest software transmission updates she appears to shift better...not the "hunting" I experienced before...so that's a positive outcome...overall the wife and my 17 year old son (who has commandeered the Disco to take to school a few times) and myself love how she rides.
 

·
Registered
Joined
·
590 Posts
Do us a favor and look at your service ticket. Please let us know what it says as to the trans update.

Thanks!
 
1 - 4 of 4 Posts
Top