Discovery Sport Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
14 Posts
Can I ask, is there a brake controller LR intended to plug into that, without adapting? Is that a LR part that exists?
 

·
Registered
Joined
·
14 Posts
Well I installed the Curt 51120 Controller using the 51322 Cable and it doesn't like it. It has a bunch of issues so I assume the 51322 is wired wrong for my 2016 despite the indications it should work. It has the red dot on all the time, which the manual states means the red wire is connected to the wrong side of the stoplight switch or the wrong switch all together. With the output set to minimum, with no trailer if I step on the brake the display shows 0.0 and I don't think it should. If I put an output adjustment in it at all I will very briefly see 0.5 or even 1.0 as it ramps then it says OL which is Overload on the blue wire, or a short. Considering the 7 pin is the factory piece plugged into the factory harness at the back, and the plug under the dash is OE for a trailer I hope its the cable from the controller to the vehicle.

I am going to start by unplugging the 7 pin harness altogether at the back and see if it persists.

Does the vehicle always show the picture of a trailer when you hit the brakes? I tested a 4 pin trailer before the controller was installed and every time you hit the brakes the green trailer icon comes up while the brake is depressed.

All the lights work great. Hoping its something easy. I was hoping for plug and play but the Landrover always has different ideas.
 

·
Registered
Joined
·
14 Posts
Well good job Curt. Problem was pretty obvious. Someone pinned out either the adapter end or controller end in reverse. I just trimmed the locating tab off and it slides in backwards which fixes the wiring. Of course the reverse wiring popped the 30A Low Profile Jcase fuse and those aren't as easy to just stroll down and get. Plug and play wasn't all it was cracked up to be.

 
1 - 3 of 3 Posts
Top