Discovery Sport Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi all,

New to this forum and really hopeful that you can help. I have a 2017 Discovery Sport HSE Black with InControl Touch pro navigation and out of the blue a week or so ago, the media app froze on "media" and will not open when I press it. It won't even pick up my phone as a media player when I plug it in so I can't even lay the radio. It has also stopped the Bluetooth from being visible to any phones.

I have (at the recommendation of the dealer) disconnected the battery for 10 minutes, but it has made no difference. They now say I need to book it in for a check over at the garage, but as that is nearly 300 miles away, I was wondering if anyone had any other suggestions before I did so?
Thanks for your help!
Glen
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #2 ·
Hi Folks,

I'm new to the forum and although I’m sure that I can’t be the first person to have this issue, I can’t find any other open threads on it, so here goes. I have a 3 year old Disco Sport Landmark and a month after the warranty has run out my screen has just stopped working (typical!). The radio came on when I started the car but went off about 30 seconds later and when I looked up the screen was black and my phone had stopped charging from the main USB in the centre storage box.

I have disconnected the battery and reconnected it again and taken all of the fuses out of the relevant box 4 in the boot and checked they are not blown, left it switched off and locked for several days but still nothing.

Any suggestions?

Thanks,
Glen
 
1 - 3 of 3 Posts
Top