Discovery Sport Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
My 65 plate Discovery Sport 2.0 Auto had a complete engine replacement in September 2018 as it blew up on the motorway - white smoke, strong smell of fumes following quick Restricted Performance error message. It was replaced under warranty by Landrover and I have a copy of the Invoice for £16,037.39! This morning I noticed the heated seats and steering wheel weren't working. Just headed off somewhere and the car started making a whistling noise, strong smell of fumes and then a brief message came up and disappeared - think it said "Charging fault" and then white smoke started to come out from under the bonnet. Turned off engine and waited for smoke to disappear. Limped half a mile home at under 10 miles ph and parked up. Anyone got any ideas? Tried Landrover but usual terrible service - car is no longer under warranty despite having had to have a completely new engine at under 3 years old!!!
 

·
Registered
Joined
·
113 Posts
this sounds horrible - most people here experience some sort of frustration but what you describe is a disaster.
I don't know the Consumer Protections laws in the UK ....you should look into that...even if the car is out of warranty.

Sorry
 

·
Registered
Joined
·
3 Posts
My 65 plate Discovery Sport 2.0 Auto had a complete engine replacement in September 2018 as it blew up on the motorway - white smoke, strong smell of fumes following quick Restricted Performance error message. It was replaced under warranty by Landrover and I have a copy of the Invoice for £16,037.39! This morning I noticed the heated seats and steering wheel weren't working. Just headed off somewhere and the car started making a whistling noise, strong smell of fumes and then a brief message came up and disappeared - think it said "Charging fault" and then white smoke started to come out from under the bonnet. Turned off engine and waited for smoke to disappear. Limped half a mile home at under 10 miles ph and parked up. Anyone got any ideas? Tried Landrover but usual terrible service - car is no longer under warranty despite having had to have a completely new engine at under 3 years old!!!
I could have written the above post, did you get your engine resolved second time? We have a 2015 that seized at two years, under warranty had the engine replaced, two years later it went again!
 

·
Registered
Joined
·
1 Posts
I could have written the above post, did you get your engine resolved second time? We have a 2015 that seized at two years, under warranty had the engine replaced, two years later it went again!
HI Anne, I've just run into similar issue with a 161 reg. I understand the first was covered under warrenty, was the 2nd also? Of course mine is out of warrenty but not willing to accept the full cost when again I've done nothing wrong in my eyes. No warning lights....car has a full Land Rover service history. Was due a regular service and engine went 2 weeks before the service date....
 

·
Registered
Joined
·
3 Posts
Unfortunately my second is not under warranty either but I think LR will do something, however it has been several months, supposedly i will hear something this week. are you sure you are not under warranty, I was just six months out on the second engine?
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top