Discovery Sport Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have just had this code come up on my 2015 DS L550

I have read various posts on here and on the Evoque forums and it seems a common problem, most likely the telematics module needs replacing or the back up batteries need replacing.

Does anyone know where the module and batteries are located in the car? Also is this something a reasonably competent DIY’er can do?

I don’t really want to pay dealer prices when you can get second hand units on eBay for less than one hours charge from the dealer.
 

·
Registered
Joined
·
5 Posts
I have just had this code come up on my 2015 DS L550

I have read various posts on here and on the Evoque forums and it seems a common problem, most likely the telematics module needs replacing or the back up batteries need replacing.

Does anyone know where the module and batteries are located in the car? Also is this something a reasonably competent DIY’er can do?

I don’t really want to pay dealer prices when you can get second hand units on eBay for less than one hours charge from the dealer.
Hello mate,
I have the same problem with the SOS Limited Functionality, I bought a car from auction whoch been “Stolen and Recovered”, since I have the car it always showed me in the dash “SOS Limited Functionality”, I hve change the battery and still the same… in the last 2 months I been trying to find the “Telematics Control Unit” because the error comes from there as I’ve been reading a lot about it and finally this evening I found it, it is located in the boot driver side where you actually have no access, you have to unbolt the 2 bolts on the bottom which holds the plastic and then gently pull the cover off and you can see it first under the window!
My problem is that the cables RED and Blue were disconnected and also no backup battery on, I will try to buy a battery somehow and put it back and I’ll come up with an update to let you know if I can get rid of the “Error” or not!
Cheers
 

·
Registered
Joined
·
3 Posts
Hello mate,
I have the same problem with the SOS Limited Functionality, I bought a car from auction whoch been “Stolen and Recovered”, since I have the car it always showed me in the dash “SOS Limited Functionality”, I hve change the battery and still the same… in the last 2 months I been trying to find the “Telematics Control Unit” because the error comes from there as I’ve been reading a lot about it and finally this evening I found it, it is located in the boot driver side where you actually have no access, you have to unbolt the 2 bolts on the bottom which holds the plastic and then gently pull the cover off and you can see it first under the window!
My problem is that the cables RED and Blue were disconnected and also no backup battery on, I will try to buy a battery somehow and put it back and I’ll come up with an update to let you know if I can get rid of the “Error” or not!
Cheers
I have the same problem. bought the car from auction and get the same error. Do you know where these three cables are connected to?

7736
Hood Automotive tire Motor vehicle Automotive design Automotive exterior
 

·
Registered
Joined
·
5 Posts
I have the same problem. bought the car from auction and get the same error. Do you know where these three cables are connected to?

View attachment 7736 View attachment 7736
That has to be the Comunication Module, that 3 cables has to go into it underneath on the bottom, the thick ones red and blue on the left and thinner one on the right, you have to check also if you have the battery on, if you haven’t… you won’t get rid of the dashboard warning!
Let us know how it goes please!
 

·
Registered
Joined
·
3 Posts
Just put the part number of the device on ebay and realised that those three cables go into the back of the box. Will do tomorrow and post the result here.
 
1 - 9 of 9 Posts
Top