Discovery Sport Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
84 Posts
Discussion Starter #1
Been away from the forum for a while, apologies, been super busy.

Went in for the 40k mile serivce about 10 days ago. Different dealership, no up-selling with this dealer, total cost around $600.

Getting a frequent SD Card Read Error, currently only at start up of the car, resets and good to go the rest of the trip. The dealer game me the usual run around about not touching the card in its receptacle - got the error again within a few minutes of picking up the car from the dealer - the second time I started the car. No, I'm NOT touching the card in the console and my console has next to nothing in it. They usually have to be persuaded to replace the card. IMHO poor design, the cards go bad after a few miles, they just don't play nice with the receptacle.

Check engine check light still intermittent for about 12k miles now - no adverse consequences that I can tell. Three attempts to fix all for naught. This time they replaced O2 sensors in the manifold - had the engine check light the next day, about 400 miles later. Dealer very sorry, says bring it back and they will try again. Great but they are 325 miles away...

All else good, mileage goes up noticeably after every service. Picking up a few rattles here and there but at 40k miles what am I supposed to expect?

SD Card Read and Engine Check Light errors seem to be a regular part of my eccentric relationship with this car now.

:nerd:
 

·
Registered
Joined
·
84 Posts
Discussion Starter #2
Only in Texas...

Back on 2-July I had one of those trips I think you can really only have in Texas. The attached photos will validate but at 6:52p I had arrived at my destination after driving exactly 475 miles in 6hr 47mins for an average speed of 70mph [sorry for the black out - you do not need to know my maximum speed for this discussion - that's personal between me and my LRDS]. BTW that's not really hauling the freight as we do have speed limits here of 80/75mph.

I managed to drain the tank during the trip, 316.9mi on one tank, I put in right at 17gal, the gas gauge had just given me a zero miles reading. According to the car it was 20.6mpg but my math says it was 18.6mpg. Not bad - lots of hills, many small towns and a long stretch of two-lane highway, so a fair amount of passing slower traffic. Car says 69mph average speed which I feel is about right even if the mileage per gallon was off.

Only in Texas?

>:D
 

Attachments

·
Registered
Joined
·
84 Posts
Discussion Starter #3
P.S. Planning on putting in an order for a new 2017 LRDS in the next few weeks. Do not want to be driving this car past 50k miles when the warranty runs out. Figure I'll hit 50k right around the end of the year/early next year. Dealer says that's about when they should start getting in 2017 orders, so a little Christmas or maybe New Years present for myself! If I hit 50k in Jan-17 I will have had the car a total of 19 months chronologically but with the 25 days in the shop for the rear differential replacement plus time to repair the roof rail installation I will have only had about 18 months to drive it, so approx 2.8k miles per month average.
 

·
Registered
Joined
·
311 Posts
Thanks for all the chronicaling. I too am looking to upgrade to the 2017. I am very hopeful the little gremlins will be out of this revision.
 
1 - 4 of 4 Posts
Top