Discovery Sport Forum banner
1 - 1 of 1 Posts

·
Registered
Joined
·
7 Posts
Hi guys, I need your opinions before I call the dealer back again for the possible 4th visit in 1 1/2 months:

I picked up my DS from the dealer this morning, it was in for a possible 2nd row rattle and bunch of other stuff. When I brought the car in, I asked them to check for the fuel gauge issue (LTB000830NAS1). They did find something, and here is what they did:

======================================
CAUSE: 889003 INSTRUMENT PACK - SYSTEM DIAGNOSIS

INCLUDES CONFIGURATION OF NEW ECU

PART#: LR073349

INST CLUSTER SOFTWARE UPDATED INS CLUSTER SOFTWARE AS PER BULL LTB00830 ADDITIONAL TUNE FK72-14C088-DA ADDED FOR THIS ISSUE
======================================

By looking at the description, it looks like they replaced the instrument panel (I checked the part is the "Instrument Cluster"), new ECU (???), and flashed software fix.

Here is what I am worried:
Right after I picked up the car and started driving, the Intelligent Stop/Start no longer works!

My DS usually has the auto stop/start kick in pretty normal when it stops at red light, but today after the fix the feature never kicks in. I then intentionally turned off the AC and radio, still no auto stop/start. The auto stop/start indicator is on in the center console button, when I pressed the button on or off, the instrument panel did say either Intelligent stop/start on or off correctly, but again the feature never clicked in every stop.

Is this the new ECU fault? or the Instrument Cluster fault? or the software they flashed is bad?

Thanks guy!


I had the Auto Stop problem after the Instrument Cluster/ECU install 3 days ago but it cleared up after a day and is now ok.
But did the install fix your petrol gauge problem? I have the same thing, where the 18.5 gallon tank says empty but I can only get 13.5 gallons in.
Thx,
KevLr
 
1 - 1 of 1 Posts
Top