Discovery Sport Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
I recently installed LR brand rails/crossbars and noticed there's wind noise when I get up to speed on the freeways. Anyone else notice this or did I install it wrong?
 

·
Registered
Joined
·
17 Posts
Discussion Starter #3
Yea I expected some noise but it seems exceptionally loud. Don't want to have to use a wind fairing cuz I'm not a fan of how they look. May just take it off for long trips when its not being used but that's kind of a pain.
 

·
Registered
Joined
·
588 Posts
yes noise is normal.
I get a whistle at 45MPH and gets louder.

Use a fairing to eliminate the noise....
 

·
Registered
Joined
·
311 Posts
Mine have some noise but are not horrible by any means. Be sure the bars are installed the correct direction. The dealership installed mine wrong and they were much louder.

The fat side of the cross bar faces forward and the pointer skinnier side faces the rear of the car.
 

·
Registered
Joined
·
588 Posts
Mine have some noise but are not horrible by any means. Be sure the bars are installed the correct direction. The dealership installed mine wrong and they were much louder.

The fat side of the cross bar faces forward and the pointer skinnier side faces the rear of the car.
Yours must be Whispbar ?
 

·
Registered
Joined
·
31 Posts
I have a similar issue. I had zero noise until I installed the LR brand bike carriers. To install them, one must remove the rubber strip that runs the length of the cross bar. This reveals a track in which the bike carriers slide and then are locked down. It is very easy to install and remove them. However, the expose track creates a very loud whistle at any speed. I thought about cutting the rubber strip to cover the remaining exposed track. Before doing so, I have called the local LR dealer to see if they have a better solution.
 
1 - 9 of 9 Posts
Top