Discovery Sport Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
113 Posts
Discussion Starter #1
I downloaded the app from Land Rover.... I think the idea behind it, is great but I have two problems that I feel are extremely annoying:
1. The remote start works only about 50% of the time....I mean seriously...I may try 4-6 times and just give up.... the next day, it may start fine at first attempt and the following day again....won't start at all or only after n-th attempt.
2. About once a month I get completely logged off.... so as the app starts I have to log in with the pw... not a big problem but annoying...since I do use the app frequently and want to stay signed in.


What is your experience with it ?

PS: Android phone - no issues with stability, app never crashed
 

·
Registered
Joined
·
588 Posts
Yes, same here.
Sometimes the car reports that the car is unlocked when it is really locked...

I noticed LR does not update the app frequently like other apps.

Maybe their app developer is not paid enough to make constant changes ???
 

·
Registered
Joined
·
68 Posts
Mine has been working very good lately. At first it would have similar issues but it hasn't happened in a while now.
 

·
Registered
Joined
·
1 Posts
I downloaded the app from Land Rover.... I think the idea behind it, is great but I have two problems that I feel are extremely annoying:
1. The remote start works only about 50% of the time....I mean seriously...I may try 4-6 times and just give up.... the next day, it may start fine at first attempt and the following day again....won't start at all or only after n-th attempt.
2. About once a month I get completely logged off.... so as the app starts I have to log in with the pw... not a big problem but annoying...since I do use the app frequently and want to stay signed in.


What is your experience with it ?

PS: Android phone - no issues with stability, app never crashed
Hi there,

Just as a advice.
1. make sure you have good network coverage in your area.
2. Ur phone's Android/IOS is up to date including app.
3. Try to visit the dealers, report your issue, make sure they update the software on following:
Telematics, Infotainment, PCM & BCM.

This should clear above issues.
Best Regards.

JLR Engineering Support
 

·
Registered
Joined
·
56 Posts
It seems Land Rover has updated the app a couple days ago. For the last couple days, the app would crash on startup, so today I un/reinstalled the app on my iPhone and it works like a charm! I saw the newest version is only a few days old. I would say that it is even faster and smoother than before. Uninstall the app, reinstall it from the Appstore or Play Store and see if that helps.
I did put in a request with Land Rover support to allow the seat heaters to be turned on with remote start. My car will be toasty in the morning and my seats still 35 degrees! I'm sure they love the input :|
 

·
Registered
Joined
·
68 Posts
Yeah, mine did the same thing with the new update, crashed and had to remove and reinstall. I was afraid I'd lose history but I didn't so that was cool. I agree that it would be nice to turn on the heated or cooled seat options.
 

·
Registered
Joined
·
113 Posts
Discussion Starter #7
Upgraded the app - no issues with stability on Samsung S7, HOWEVER, still not able to start the vehicle half the time.... no rhyme or reason...sometimes it will start on n-th attempt...sometimes it won't start at all and most rare is that it will start on the first attempt.

frustrating - don't offer features that do not work reliably...
 

·
Registered
Joined
·
311 Posts
I have been using the app since my purchase and was so excited when it was upgraded to support Android Wear. I have an Asus Zenwatch 3 and the top tactile button is programmed to open the app directly. I love showing off and starting my car with my watch.

I do agree, connectivity is wonky at times, but it mostly works... Sadly "mostly" is a good rating in today's tech market and buying experiences.

I also have my app log me out about 1x per month. Better than my WaWa app that seems to log me out every other day.

I have noticed an issue with the car reporting windows closed, etc. I make sure to never have two windows ever reach the closed position at the same exact time and this seems to have solved that issue. If it ever reports erroneously that a window is open, just open all your windows and then close them one at a time.

One time it did say my car was unlocked when it was not. I just told the app to lock it then retried the climate start and it worked.

I do wish there was a manual refresh button on the app. It is better than it was when first released, but sometimes takes a while to update or reports a status from a day ago.
 

·
Registered
Joined
·
311 Posts
Anyone else using the app with their Android Wear watch?

Mine stopped working when Android Wear changed with an update to Wear OS. It gets frozen on my watch stating I need to login on the phone's app.... Which I am. Bummer it stopped working. I loved it on my watch.

Please let me know if you have the same issue or have it working.

Thanks!
 

·
Registered
Joined
·
2 Posts
My InControl App functioned properly for about 1 month but now doesn't work. Whenever I go to use it the App won't lock or remote start my car...it says "Remote start is not available - Vehicle is locking". This message has been coming up for a couple weeks and I can't seem to uncover any button I might have hit that would cause this locking issue/message.

Has anyone seen this before? Thoughts?
 

·
Registered
Joined
·
2 Posts
I have just got a new DS. The dealer set up the app and registered everything. So far it only logs my trips. So i guess i know comms is kind of working. I can't remote start or use any of the other features. It's frustrating as this was a big feature I wanted in a new car. It's hot in Australia and I need to cool the car before getting there:)

Hoping to retry everything again but any advice is appreciated.

My InControl App functioned properly for about 1 month but now doesn't work. Whenever I go to use it the App won't lock or remote start my car...it says "Remote start is not available - Vehicle is locking". This message has been coming up for a couple weeks and I can't seem to uncover any button I might have hit that would cause this locking issue/message.

Has anyone seen this before? Thoughts?
 

·
Registered
Joined
·
10 Posts
I think a lot of these features are country dependant. I have the journeys like you and can lock or open the car remotely but i can't 'beep and flash' or remote start the car which is a real shame.
 
1 - 14 of 14 Posts
Top