Discovery Sport Forum banner

21 - 24 of 24 Posts

·
Registered
Joined
·
84 Posts
Discussion Starter #21
Next Update - Just Below 35k miles

Still getting the occasional SD Card error - Nav won't work so you have to reboot the entire system. It does and stays fixed... till next time Mostly happening now at engine start, maybe four times since the dealer replaced the card.

Replaced all four tires. My LRDS came with Perellis. 4/32 of tread on two original tires, 5/32 on the one the dealer had to replace at 10k miles when they popped it in their lot on a parking bumper and 7/32 on fourth wheel Discount Tire had to replace when they botched a leak repair at around 15k miles. Tires were balanced and rotated at each of 10k, 20k and 30k services. I am keeping the 7/32 tire and buying a cheap wheel that fits the LRDS to put in my spare tire wheel-well so I can have a full-sized spare. Wow, the car drives so much better with the new tires - this is how I remember those first few weeks with the car after delivery.

Engine check light is still a persistent little gremlin. Comes and goes, car wash again and twice when ambient temps here in West Texas were 104F. Also got it again when they changed the tires, but went out the next day, go figure? Since it seems to be non-critical I'll wait until 40k miles service to have it looked at unless of course it comes on and doesn't go back out after a day or so.

All else good - drives like a rocket again with the new tires. Will put over 1k miles on the car over the week of 4-July. No major trips after that until late August so I am slowing down for now on mileage.

;)
 
  • Like
Reactions: petcha

·
Registered
Joined
·
258 Posts
Been away from the Disco Forum for too long, my bad...

Rear differential seems fixed. Other than that nothing much else to report. No news is good news!

:nerd:
Well, I just started getting the two-wheel drive error today. Happened twice. I've been moving the car in and out of the garage to work on my garage door and didn't notice the error, but based on this post, and your other thread on two-wheel drive, I suspect it's not going to go away easily and might even need a rear differential replacement. Sheesh. Oh well. At least it's still under warranty. I'm about 14 months owning it and 16.5k miles so far. We'll see what happens. I'm hoping it'll just go away. I had several other system failures at times that were a one-time thing (e.g., AEB failure).
 

·
Registered
Joined
·
84 Posts
Discussion Starter #23
My research on this says that sometimes the error occurs when there is a pressure drop read by the sensor in the rear differential. It can be transient and not an indication of a serious problem. Apparently the brain in the transmission shuts down the rear differential to avoid damage when it gets such a reading. It can also mean a faulty transmission fluid pump, although I'm too sure about that one. In any event dealers may want to replace the whole thing to be sure. Mine has been fine ever since the replacement. I'm at 40k miles now, replaced at 20k, first error two-wheel drive light right about the same time as you. If it resets when you shut off the car, you are good. You can also drive the car safely in two-wheel drive mode indefinitely - its just not as much fun... It is bummer when it starts happening all the time though.
 

·
Registered
Joined
·
258 Posts
My research on this says that sometimes the error occurs when there is a pressure drop read by the sensor in the rear differential. It can be transient and not an indication of a serious problem. Apparently the brain in the transmission shuts down the rear differential to avoid damage when it gets such a reading. It can also mean a faulty transmission fluid pump, although I'm too sure about that one. In any event dealers may want to replace the whole thing to be sure. Mine has been fine ever since the replacement. I'm at 40k miles now, replaced at 20k, first error two-wheel drive light right about the same time as you. If it resets when you shut off the car, you are good. You can also drive the car safely in two-wheel drive mode indefinitely - its just not as much fun... It is bummer when it starts happening all the time though.
After my error appeared, it never went away. I took it in today and they are ordering the pump. Won't be fixed until late next week. We'll see how it goes. I'm concerned that it may come back and they'll have to replace the differential. The only saving grace is that it seems as if I'm getting a few more miles to the gallon!
 
21 - 24 of 24 Posts
Top