Discovery Sport Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Has this happen to anyone?
When the start-stop is activated, my Disco completely shut off while I'm waiting for a light to change. (i have to restart)
It happens once in a while and the dealer do not find any error codes.
 

·
Registered
Joined
·
588 Posts
Yes, I had that happen.
When this happens, take a look at the transmission selector.
You may notice the "D" will flash on/off.

I had this taken care of by the dealer - they had to reprogram the powertrain.
 

·
Registered
Joined
·
73 Posts
What is happening to me is that 8 out of 10 times the Eco Auto Stop does not work. When it does engage, the RPM shuts down for a bit but them kicks back in even with my foot still on the brake at a red light. LR said they found nothing wrong with it but its still happening. It's back in the shop on the issues now so hopefully they will look at that also.

Also after they washed it last time got condensation in the tail lights lens....addressing that issue also

I have never had the engine shut off completely.
 

·
Registered
Joined
·
56 Posts
What is happening to me is that 8 out of 10 times the Eco Auto Stop does not work. When it does engage, the RPM shuts down for a bit but them kicks back in even with my foot still on the brake at a red light. LR said they found nothing wrong with it but its still happening. It's back in the shop on the issues now so hopefully they will look at that also.

Also after they washed it last time got condensation in the tail lights lens....addressing that issue also

I have never had the engine shut off completely.
Not sure where you live but cold affects the Auto Stop. In chicago mine basiacallly didnt activate for a few weeks i had no idea what was going on. It got warmer and all the sudden it worked. I called LR said if its below like 30 to expect it to not engage.
 

·
Registered
Joined
·
73 Posts
Winter is over where been in the 65 to 70's during the day now...gave me a Jag loaner to use, same thing was happening.
 
1 - 5 of 5 Posts
Top