Discovery Sport Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello, I've been having issues with my Discovery Sport HSE Luxury starting every time I go to fuel up. The vehicle will not start with the push of the button. I have to press push to start 3-5 time and if that doesn't work I step on the gas then it will eventually start. I had it diagnosed at the dealer and they said it was a sensor so had that replaced for $490 and it still doesn't start! The dealer diagnosed it again and now it says all of the cylinders are miss-firing. They said that's unusual for all to be miss-firing. Has anyone had the same issues or any recommendations?

Thanks!
 

·
Super Moderator
Joined
·
360 Posts
Strange that it only happens when you fuel up,, does it start normally the remainder of the time? Do you only fill up when the tank is empty?

I had misfires and it was traced to the fuel injectors, and low pressure at the high pressure fuel pump.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Hi Bill, Thanks for replying! It starts no problem when not fueling. I've been keep the engine running to avoid the issue. I was filling up when empty. I've started filling up with about 1/4 tank now.
Did you have the fuel injectors clean or anything?
 

·
Super Moderator
Joined
·
360 Posts
No, two injectors where sticking and had them changed out. Dealer did poor job and I smelled gas fumes. Other dealer repaired leak on the fuel rail and changed out the other injectors just in case, they do love extra warranty repairs.

I always run either 94 or 91 octane non ethanol fuel (unless travelling in the USA ) and for the most part fill up prior to getting to the 1/4 mark to prevent fuel pump damage or dirt plugging it. Mainly use Chevron fuel or Shell and they both have great cleaners in them. You can try a good injector cleaner but most products are designed to clean the valves and do little for direct injection.

Strange thing is the fuel economy readout was always 14% out compared to actual calculated values. Ie: car would show 11L/100 KMs and when I calculated it would be 12.5L/100KMs. Now with new injectors it is out over 19% and would read over 13L/100KMs. But the car seems much quicker.
 
1 - 4 of 4 Posts
Top