Discovery Sport Forum banner

41 - 57 of 57 Posts

·
Registered
Joined
·
2 Posts
I had taken my new (500 miles) DS in about 3 weeks ago because the check engine light had come on and stayed on for about a week. The service advisor came in and said that it was not on when she pulled it in to the service bay, even though it was on when I parked about 5 min earlier. She said they would check it out anyway, so off I went in my XF loaner.
She called later that day to tell me there was an "exhaust leak" that they had fixed, but they needed to keep it overnight to make sure it was fixed. Not a problem, picked it up, light was off, and away I went.
About a week after that, on my way to Whistler for a ski weekend with a couple buddies, the light came on again about 10 miles into the trip. Holiday weekend and all, couldn't get hold of the service dept to make another appointment, so I called when I got back. Advisor said that JLR is aware of "an issue causing the check engine light to come on repeatedly." She then said that there is no fix available at this time, but she would contact me with any update and that I should just ignore the light if the DS "is running fine."
I'm mostly worried because I thought the car was "running fine" the last time the light came on, and there was an exhaust leak that needed to be repaired. Has anybody else heard of this issue? Thanks!
Bought a new Land Rover discovery sport in Ireland this year. Engine warning light came on, dropped it into dealer and its now been over two weeks and still no sign of resolution. Appears to be 2 warning lights tripping each other alternatively. First time I have had a problem like this with any car in 30 years. Not happy and worried about car for the long term. Anyone else having similar issue So?? Alan
 

·
Registered
Joined
·
41 Posts
I have a 2016 Disco HSE ... I've had my check engine light come on twice. Both on my way back from weekends in Tahoe. First time it was O2 sensor, misfire on cylinder, running lean. The car went into limp mode and wouldn't push over 2k RPMs. This was at 2,200 miles approx.

Second time, misfire on three of four cylinders, running rich and O2 sensor. Car didn't go into limp mode this time but was sluggish on accelerator. This was at 3,300 miles approx.

They are figuring it out, fingers crossed nothing major, although I have the privilege of driving an XKR for the next days.
SLangsam510 what was the end results in your case? I'm in a similar situation where the car went into the dealership with check engine on - they investigate and found misfire of cylinders 1 & 2.
It is now 5 days later with the DS computer completely down - died while they were running some software updates - recalls.
 

·
Registered
Joined
·
4 Posts
I just bought DS HSE 2017 and had 400 miles on it and Check Engine light came on after I fill my first tank at Costco. Anyone has issue with 2017?
 

·
Registered
Joined
·
211 Posts
Just a thought - but check to make sure your fuel filler cap is 100% tight. Even a slight gap/bad seal will cause the CEL to come on.
 

·
Registered
Joined
·
84 Posts
Get Used to It

Just traded in my 2015 LRDS for a 2017 at 22 months and 54,255 miles. Check Engine light has been my buddy for about 30k miles now and was lit up the day before the trade in. After I sold them the car it came on in their parking lot LOL! After at least 4 attempts at servicing the problem I just gave up. Happened almost every time I filled the car up with fuel but I went almost three months this winter without it coming on. I am probably wrong but it seems to me that ethanol in the gas trips the sensors. Never had an issue driving the cat at any speed, under any condition with the engine light lit up.

Now for my other annoying problem, SD Card Read Error - that also never went away and asking the dealer to service it was a joke. "Don't touch the card" is what I was always told - I wasn't touching the card, hadn't touched the card, it just loved to come on whenever I really needed the GPS in a hurry. This problem has been with me from about 10k miles, usually a few restarts of the system would fix it. HOWEVER it really didn't like Oklahoma for some reason and I had to drive through about half of OK without it on one trip.

British eccentrics...

So I get a restart now. We'll see how long it takes for me to get SD Card Read and Check Engine Light errors.
 

·
Registered
Joined
·
588 Posts
i have a DS bought new in 2016.Its been one light after the other.Never again.
Its back to BMWs for me !!!!!
Don't be too quick to go back to BMW.
I have had 17 years of BMW and loved their E models.
When BMW changed over to the F and G models, their drive quality dropped like a rock.
Unless you like the new models with soft ride, no connections to the road, and awful steering - go for it.

I am patient as I expect a small niche brand like Land Rover to have issues.
For a fact, BMW back in the 80's and 90's had many similar electronically with multiple computer glitch issues but recently they put in a lot of $$ into R&D to prevent newer models from suffering the same issue....

I will wait for Land Rover to iron out their issues because I love the DS drive as it reminds me of my first BMW: 2000 X5 E53 with fixed 40/60 4WD traction road magnets!

To each his/her own....
 

·
Registered
Joined
·
84 Posts
Hey quick update here. The new 2017 Disco Sport has 13.5k miles on it already and trouble free to date (knocks on wood). No check engine, no SD card read errors. Still a little early for both but so far so good. Only problem was some idiot passenger of the car next to me at work (we have assigned spaces) scratched the heck out of my driver door (probably with the bling on a purse - sorry if I sound chauvinist). 20k mile service scheduled for 30-Oct. Truck on!
 

·
Registered
Joined
·
1 Posts
Hey quick update here. The new 2017 Disco Sport has 13.5k miles on it already and trouble free to date (knocks on wood). No check engine, no SD card read errors. Still a little early for both but so far so good. Only problem was some idiot passenger of the car next to me at work (we have assigned spaces) scratched the heck out of my driver door (probably with the bling on a purse - sorry if I sound chauvinist). 20k mile service scheduled for 30-Oct. Truck on!
Great LRDSnTexas.
Good news. How much have you paid for the trade?

thanks
emisintra
 

·
Registered
Joined
·
84 Posts
emisintra: don't remember exactly, maybe $23k was the value I got for the trade-in, remember even though I had the 2015 LRDS only 23 months the car had almost 55k miles on it...
 

·
Registered
Joined
·
8 Posts
The SD card can get hit easily like just putting things in the storage area. I accidentally touched it when feeling around for the USB plug. Had the SD card issue until i finally pushed it to take it out and pushed it back in.
 

·
Registered
Joined
·
8 Posts
Second CEL

It came on at almost 1K miles, now at almost 3K miles. The appointment wait time at the dealers is 2 weeks. By the time I was ready to bring it in the first appointment the light turned off after a week. last one lasted over the weekend and turned off before I could take it to the dealers.
 

·
Registered
Joined
·
63 Posts
there is a campaign out N118- its VIN dependent and has something to do with oil level checks- I have had many issues with my disco but no check engine lights (yet!)- apparently though my VIN was in the range of this rollout so the dealer updated the software..

cant tell you if it worked or not as I never had an issue- but maybe chat to the dealer and see if this campaign applies to your car
 

·
Registered
Joined
·
113 Posts
So sadly and to my frustration I got Check Engine light on today.... it's relatively warm here in NJ today (above freezing) so not fitting with some other posts here. I checked the fuel tank is properly closed - will check other fluids tomorrow....while the car seems to be driving OK....there seems to be some off sound...almost like a hiss when accelerating...never noticed that before.

I'll be honest.... I will call the dealership tomorrow and if they try to give me hard time with appointments - I will be really pissed off.
An almost $50,000 vehicle with 4000 miles and acting up ??? WTF ?? They better compensate me with a quality service experience and a nice loaner...though ideally I would prefer not to need it at all....
I have to admit - back in college when I was driving older, used cars in the $5,000 price range I didn't mind if they had issues.... but for the last 14 years I have been getting used to luxury vehicles that (not sure...maybe just luckily ) had no real issues...certainly nothing major and nothing in the first 10k miles....

This is ruining my experience with this car and really damages the brand for me.....

BTW.... I have been posting in the other thread about the suspicious smell of oil fumes coming when heat is on....very characteristic of hot oil....not exhaust fumes but actually engine oil.
Wondering if there is a link somewhere....I didn't notice any stains on the engine a few days back and nothing on the garage floor.
 

·
Registered
Joined
·
8 Posts
I got CEL on my 2016 HSE at around 30k. I did not notice any changes in behavior and CEL was on and off so I was driving for next couple of thousands, Finally, forced by upcoming inspection, I decided to visit dealer. On the first visit they found so many different errors they couldn't determine the reason for CEL. Dealer cleared CEL and log and told me to come when it will light again. As expected within couple of days CEL came on so visited dealer again. This time diagnose was clear and fuel pump was blamed. Replaced with two days (got nice blue Evoque loaner) and since then, about 5k,no more CEL!
 

·
Registered
Joined
·
8 Posts
First time we put Safeway gas in the Discovery. Check engine light on right now. I have filled it up before with only chevron, no issues.
 
41 - 57 of 57 Posts
Top