Discovery Sport Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi, I have a 2021 P300e discovery sport hybrid and the way the vehicle switches between petroleum engine and electric has changed. Previously it would cruise on a motorway at 70mph on the electric motor. Since the last software update it will no longer run electric on the motorways when cruising. It has also changed in other ways, not sure if it’s anything to do with the update. Anyone else noticed anything similar?
 

·
Registered
Joined
·
11 Posts
Hi, I haven't noticed that specifically, but I may not have updated the software. But I am also trying to understand the scope of the algorithm that controls the hybrid mode (see my earlier post). Sometomes the petrol engine appears to charge the battery (from the energy flow screen) but only rarely and I can't understand the logic.
 

·
Registered
Joined
·
1 Posts
Hi Sean,
Took the latest update over the air on 24th Sept for my 2021 Discovery Sport PHEV.
Have not tried the motorway yet but a big change I have seen is -
when diving normally in Hybrid mode and on electric motor all is perfect (as before the update)
if for any reason the petrol engine has to run then the car will not return to electric only unless I switch off and switch on (start button cycle)
Before the update if the petrol engine ran then after a small time/ distance travelled it would drop back to electric.
This is very frustrating and I am about to involve the dealership.
Can not be certain but feel sure the update has caused this as before then the car ran very well.
 

·
Registered
Joined
·
3 Posts
Hi I just got the p300e last week and have noticed this failure to switch from petrol to hybrid unless restarting. This is not what my previous hybrid did. Sounds like software issue!
 

·
Registered
Joined
·
2 Posts
Hi I just got the p300e last week and have noticed this failure to switch from petrol to hybrid unless restarting. This is not what my previous hybrid did. Sounds like software issue!
I also have an MY21 P300e and have experienced exactly the same problem - very annoying and definitely worse since the latest software update. Let’s hope that JLR rectify this pdq :(
 
1 - 5 of 5 Posts
Top