Discovery Sport Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Discovery Sport 2020
Audio system will randomly stop working. No audio with radio or CarPlay. system looks to be functioning fine just no sound. After shutting down and restarting the car several times the audio will begin to work. I have video of the problem.
anyone one else experiencing this?
This is the standard audio system not the Bose upgrade.
 

·
Super Moderator
2016 DS HSE Auto Gas/petrol
Joined
·
625 Posts
Not lately but in the past others have performed a system reboot, or a reset of the radio. Not near my car but if the screen boots up find a control that deletes all your information phone and nav and see if that helps.

For a system reset , disconnect both battery cables, wait a minute or so and the touch the cables together for a few seconds. Then reconnect the cables and recheck. You will have to reset windows, seats etc back to your settings.

Be very careful when disconnecting the battery. Use insulated wrenches and disconnect the negative cable first and reconnect the negative cable last.
 

·
Registered
Joined
·
1 Posts
Discovery Sport 2020
Audio system will randomly stop working. No audio with radio or CarPlay. system looks to be functioning fine just no sound. After shutting down and restarting the car several times the audio will begin to work. I have video of the problem.
anyone one else experiencing this?
This is the standard audio system not the Bose upgrade.
This summer I have had the same issue on DS 2015 HSE (non-Meridian). Disappeared when this summer ended. I think the reason is a high temperature and overheating of amplifier under the passenger seat. No one case for the last month, as well this summer was really hot.
 
1 - 4 of 4 Posts
Top