Discovery Sport Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi, suddenly got 3 warnings all amber. They are Camera fault; AEB not available and lane divergence not available, plus centre control panel comes on for a short while then goes off.
 

·
Registered
Joined
·
34 Posts
A blocked camera would cause all these issues. Clean in front of the camera with windex. Then look into the camera to make sure nothing is trapped between it and the glass. The camera is in front of the rear view mirror.
After you make sure the view path is clear, reboot the car: get out of the car and lock it. Wait for the the nav unit to turn black and flash off. Then open the door and start the car. Good luck, I hope you have nothing actually broke!
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
A blocked camera would cause all these issues. Clean in front of the camera with windex. Then look into the camera to make sure nothing is trapped between it and the glass. The camera is in front of the rear view mirror.
After you make sure the view path is clear, reboot the car: get out of the car and lock it. Wait for the the nav unit to turn black and flash off. Then open the door and start the car. Good luck, I hope you have nothing actually broke!
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
Thanks for all replies. Now at Dealer after 2 1/2 week wait. Diagnosed as faulty rear camera. Repair is £711! Thank heavens I am in self isolation so cannot waste money in the pub or restaurants.
Peter b
 
1 - 7 of 7 Posts
Top