Discovery Sport Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
RE: Discovery Sport 2016

Hi there, on a long journey (3 hours+) with Air Con on, towards the end of the journey the system stops blowing out cold air. If I stop the car and leave for 30 mins, it's ok again. Any guidance would be much appreciated.

This doesn't happen on short trips and doesn't happen all the time on the longer trips either.

Cheers, Graham
 

·
Super Moderator
2016 DS HSE Auto Gas/petrol
Joined
·
591 Posts
Graham

Next time it happens turn off the A/C and restart it to see what happens.
I would make sure the condenser is clean. as a first step, then have the pressures in the system checked to detect low refrigerant levels or poor mechanical problems and then as a last resort have the expensive heating controls checked out.

Curious does the heat work all the time?
 

·
Registered
Joined
·
9 Posts
That's a pretty classic symptom of low refrigerant. Of course it usually gets low because you have a bit of a leak so fixing it may involve finding and fixing that.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Graham

Next time it happens turn off the A/C and restart it to see what happens.
I would make sure the condenser is clean. as a first step, then have the pressures in the system checked to detect low refrigerant levels or poor mechanical problems and then as a last resort have the expensive heating controls checked out.

Curious does the heat work all the time?
ok, I'll try that, and if nothing I'll get it booked into the garage... The A/C usually works fine all the time, it's on;y now been on 3 long journeys that this has occered. Cheers :)
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
That's a pretty classic symptom of low refrigerant. Of course it usually gets low because you have a bit of a leak so fixing it may involve finding and fixing that.
Thanks for taking the time, I'll mention this to the garage when booking it in :)
 
1 - 5 of 5 Posts
Top