Discovery Sport Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
2020.5 MY Discovery Sport P250 SE
1AA - Fuji White
300XP - Acorn Windsor Leather Seats
017HE - Premium Interior Upgrade Pack
017TE - Driver Assist Pack
025LA - Sirius XM Satellite Radio and HD Radio
025LN - Meridian Surround Sound System
032MB - Black Exterior Pack
074KY - Technology Pack
088JU - Natural Shadow Oak Veneer
300JJ - 14-Way Heated & Cooled, Electric Memory Front Seats

Ordered: January 16, 2020
Build Date: February 14, 2020?
Delivery: March 20, 2020?

Let's see how close they are to their estimates! We are so impatient now that it is real and not just talk!
 

·
Registered
Joined
·
26 Posts
Discussion Starter #2
Actual build day was Thursday, February 6, 2020. Unfortunately it missed the boat and is waiting for the next one. Several other vehicles from the dealer placed at the same time and built on the same day are on their way with an ETA of Friday the 13th. My new ETA is March 27th. Hopefully the date will move up as new information becomes available.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #3
Picked up my 2020 Discovery Sport P250 SE on Friday. Nicest vehicle I have ever owned. I has exceeded my expectations in every way! Here is a shot outside our hotel room that evening.

20200327_203738.jpg
 

·
Registered
Joined
·
45 Posts
Looks great!!!! Love the white with black pack!

Just needs some mud on it now ;)
 

·
Registered
Joined
·
26 Posts
Discussion Starter #5
1st hiccup. The data connection stopped working once we drove off the lot. Figured it was a delay in activation because we got it on the weekend. Called the dealer's tech specialist and they can't resolve it. They called JLR corporate and were told I need to bring it in to a dealer to get the telematics reset. I have that scheduled for next Monday. That was the earliest available appointment. Hopefully it will be a hassle free experience. For now I'm using the WiFi hotspot from my phone and it is working great. Maybe I don't need to pay for another data connection???
 

·
Registered
Joined
·
26 Posts
Discussion Starter #6
It hasn't been hassle free :-(

I sat at the dealer for 8 hours yesterday while they tried to figure it out. They kept saying we finally have it figured out and are waiting from confirmation from someone at another location. They thought they finally had it fixed and the service manager brought me the car and it wasn't working when he went to show me. They were closing for the day so I took the car home while they worked on what the higher level techs thought was a "back end" problem.

Last night during the night they tried to delete my vehicle from all the systems and readd it and that failed.

Today they had me do the B-Call procedure where you hold the left overhead button for 15 seconds to reset something. That failed as well so tomorrow I'm bringing the car back and they are going to give me a courtesy car so I don't have to sit and wait.

One odd note, when trying to trouble shoot things yesterday they were using other MY20 vehicles on the lot to test some of the procedures and found another unsold vehicle with the same mystery problem.
 

·
Registered
Joined
·
7 Posts
Sucks you been waiting for over 2months for your DS. You get it, to have a problem the dealership cant fix. Has the dealership done anything to compensate your time being wasted?
 

·
Registered
Joined
·
26 Posts
Discussion Starter #8
I haven't asked for anything... yet. I'm waiting to see how they handle it when I go to pick it up after the problem has been resolved.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #9
The data problem has been fixed. I'm not sure what they did to get it going but they had to escalate to their 3rd tier support. The 1st tier is local, the 2nd tier is in NJ, and the third tier is in the UK. The service manager said in all his years there he didn't even know there was a 3rd tier so it made for a learning experience for them and also some delays with the time difference. I've got my car back and all is well.

The dealer in Ft Myers followed up with me today and they are going to reimburse me for three months of data charges since the free trial never activated and I was charged by AT&T when I set up the account.
 

·
Registered
Joined
·
7 Posts
I honestly, I dont know why there's a need for the data connection. Dont must cell phone services come with unlimited data built into their plan?
 

·
Registered
Joined
·
26 Posts
Discussion Starter #11
I have Verizon, I don't have unlimited. The data connection is not a necessity, but it is a nice convenience. I can take out my phone and set it up to provide a hotspot the car can use, or I can just not use the features that require data. I like the extra features and having the car instantly connect without any action on my part is nice. It isn't really expensive and I can always just turn it off if i change my mind.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #13
Smooth as glass, quiet as a mouse, er, no squeaks so I guess quieter than a mouse. :)
 
  • Like
Reactions: dannyt

·
Registered
Joined
·
23 Posts
Any other issues come up? Am considering trading up to current model. Despite dramas I had. It’s been great post 4th year.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #15
The only issue I had seems to have been either a configuration error in the system when the vehicle was built or at the dealership during PDI. The data SIM card did not work and was not listed in the AT&T system. The dealer and apparently the second tier dealer support in New Jersey had never experienced it and could not locate the source of the problem. It took someone in at the third tier support the UK to wipe, reset, and reconfigure everything. The service manager has been at the dealership for 9 years and didn't even know there was a third tier.

I do have an additional issue the dealer is willing to resolve, but it isn't a vehicle issue. The navigation has an update but my iMac and MacBook Pro both think the software used to perform the update is malware. Whenever I try to run the map updater program it closes down and prompts me to delete the malware from my system. I believe the problem is with MacOs 10.15.4 as it worked last month when I performed the update.

My wife and I absolutely love the vehicle!
 

·
Registered
Joined
·
23 Posts
The only issue I had seems to have been either a configuration error in the system when the vehicle was built or at the dealership during PDI. The data SIM card did not work and was not listed in the AT&T system. The dealer and apparently the second tier dealer support in New Jersey had never experienced it and could not locate the source of the problem. It took someone in at the third tier support the UK to wipe, reset, and reconfigure everything. The service manager has been at the dealership for 9 years and didn't even know there was a third tier.

I do have an additional issue the dealer is willing to resolve, but it isn't a vehicle issue. The navigation has an update but my iMac and MacBook Pro both think the software used to perform the update is malware. Whenever I try to run the map updater program it closes down and prompts me to delete the malware from my system. I believe the problem is with MacOs 10.15.4 as it worked last month when I performed the update.

My wife and I absolutely love the vehicle!
Thanks for sharing Stroh. good to know. I’m still deciding to be honest. Am still hesitant post the 2015!
 
1 - 16 of 16 Posts
Top