Discovery Sport Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Has anybody had issues with heating ventilation console illuminations lamps failing?
MY DS has been relatively reliable but just lately these lamps have been failing one by one.
First the top row that have the quick buttons for rear window heating heated seat etc failed one by one and now the bottom row have started to fail. When i say fail they don't illuminate once head lamps are on.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Hi mine has just had that problem, is there a fix or what is it from?
Hi ajk I dont know what the cause is as yet, however I suspect just port quality LED's that should last the life of the vehicle but giving up at 4-5 years. I have had my local dealer have a quick look at it and they say they have seen this before, so I have to assume its becoming common.
The issue for me is LED back lights on the AC control panel buttons with the top row now dark at night and its happening too more. Now the touch screen surrounding buttons are becoming dark. Its like a creeping death the the LED's on the circuit boards.
So the LED's cant be replaced and neither can the circuit boards so the only fix is to replace the entire Heater A/C control panel which has a cost of approx $3000.00 just to fix the LED's and I have to assume the touch screen will be the same as it looks like the same design. Total repairs could reach $5000 just to make the car driveable at night.
I contacted Land Rover Australia as my car is well out of warranty but traveled just 40,000km, they are being typically evasive and have told me to take it to the dealership for repair. This is unsatisfactory as I want a commitment that it will be repaired without costing me 20% of the cars value just to have some LED's replaced in the dash.
I am going to pursue this further as the depreciation has been horrendous and trying to sell it with this fault and the cost to repair it will make me liable under our consumer law.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
Hi Ajk
I totally agree as I am also over the local dealership as good as they appear to be the costs associated with "approved repairers" is just too much.
Like you I have owned my vehicles since new and it has been almost trouble free which is surprising considering the reputation.
But now this minor issue with a few failing LED's is stupid and obviously JLR expected them to last a life time given they are part of a circuit board and obviously cant just be replaced independently within the board. At the rate of failure and as its in other circuits boards I can only assume that these LED's are either a badge batch or just poor quality. My advice from numerous sources says that as only a few on the board are failing it can be only two things the component or the circuit board with a dry joints (which means the circuit boards are failing). Both these failures should not happen. Discovery 4's had a similar issue so I am told and they are about the same production era but I am told you can get replacement boards for these vehicles.

Keep me posted on your findings and I will do the same.
 
1 - 3 of 3 Posts
Top