Engine doesn't start - Land Rover Discovery Sport Forum
User Tag List

 
LinkBack Thread Tools
Old 04-28-2017, 12:52 PM Thread Starter
Junior Member
 
Join Date: Apr 2017
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Engine doesn't start

Bought a Discovery Sport in Geneva Switzerland 2 & half months ago and had major issues! During my trip through Spain & Portugal less than one month later the car din't start a morning in Marbella Spain. Had it towed to Salamanca a major Spanish importer and had to wait a week to get it fixed. Was told that it was a major breack down. The engine electronics had shorted and had to be replaced with new components. They guaranteed that after the repair it would not happen again. But yesterday in Lisbonne it did! Again same thing. I have lost confidence in this car and called the Swiss dealer to eventually have it replaced. But apparently this is not possible. So I'll will have it fixed and trade it to my usual brand Audi...Very bad experience.
wham1000 is offline  
 

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Land Rover Discovery Sport Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Thread Tools



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome