Banging sound from under the car when pressing down hard on the gas pedal - Land Rover Discovery Sport Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 4 Old 03-05-2016, 01:17 PM Thread Starter
Junior Member
 
Join Date: Oct 2015
Posts: 13
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
(Thread Starter)
Banging sound from under the car when pressing down hard on the gas pedal

I've noticed that this banging sound happens more frequently under colder outside temperature. It's coming from the bottom of the car when I press hard down on the gas pedal. Especially one day when it's only 10 degree F outside, I could hear it as soon as it reaches 10 mph. I don't hear it when the car is totally warmed up though. So I brought it back to the dealership, I left my car there for them to duplicate the sound, but they couldn't hear anything. Does anyone has any of this experience?

redd
Road Tiger is offline  
post #2 of 4 Old 03-20-2016, 04:54 PM
Junior Member
 
Join Date: Dec 2015
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Yes we do. When we accelerate hard we hear a loud knocking/tapping noise. The dealer heard but couldn't figure it out. They claimed it happened on other DSs on their lot as well. The directions to us were to not slam on the gas when cold. BTW, it seems to be getting worse and I notice it when the car is warmed up as well (not as bad).

The dealer thought the muffler may have been loose and rattling. However, I think it's more engine related and not body related. I plan to bring it back as it seems to be getting worse.

Here is a link to quick video I recorded with the sound...is this the same as yours?
Movies - weatherman
Pabloa3 is offline  
post #3 of 4 Old 03-20-2016, 06:16 PM
Junior Member
 
Join Date: Oct 2015
Posts: 6
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
I get the same thing and I'm in warm weather all the time. Seems to happen when I'm turning and accelerating at the same time.
danielmaui is offline  
 
post #4 of 4 Old 06-03-2016, 01:22 PM
Junior Member
 
Join Date: Jun 2016
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
This sounds similar to what I had in mine... turns out the skid plate under the (viscous coupler?) some part of the drivetrain between the two front wheels was pushed up a bit - I had gone off road and knocked it up by mere millimeters. When you drive hard or accelerate hard (like off a stop or out of turns) that drivetrain component rocks down a bit and scrapes into the top of the skidplate. I literally took a crowbar and pried the skidplate down a little bit. I have pictures somewhere I will try to find and post.
heavnema is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Land Rover Discovery Sport Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome