Slow acceleration / loss of power - Land Rover Discovery Sport Forum
User Tag List
Biggles, Bill F, DiscoDisco, Discosal, horselady, JClarke

 
LinkBack Thread Tools
post #1 of 2 Old 01-24-2019, 07:29 PM Thread Starter
Member
 
Join Date: May 2017
Location: Upper midwest, USA
Posts: 59
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
(Thread Starter)
Slow acceleration / loss of power

I have something to try....
I turned off the anti-skid feature (right most button) and it "seems" to help. I did this every drive since Tuesday PM and it seemed to really change the acceleration profile. Take note of where you have the hesitation problem, then turn off anti-skid and then repeat the offending maneuver.

Let everyone know if you see a difference.

In the upper midwest US, we have quite a bit of snow and ice, a couple of times the anti-skid kicked in and it dawned on me that it behaved almost the same - so I am trying an experiment on that mode.

2017 Discovery Sport HSE
loire17 is offline  
post #2 of 2 Old 02-01-2019, 08:36 AM Thread Starter
Member
 
Join Date: May 2017
Location: Upper midwest, USA
Posts: 59
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
(Thread Starter)
Success........................................... ............................!
I've been turning off the DSC (anti-skid) function since last Tuesday (January 22).
This has really changed the performance for me.
The Slow acceleration / loss of power problem is gone, except briefly when -20F and the car is cold, so I don't count that.
This made a major improvement to the acceleration problem so many are experiencing / describing.
I personally have no problem with turning DSC off. But the decision is yours based on your comfort level.

I will try to explain the effect next time I'm in (probably in a month or so) for the yearly service.
I don't know if they will do anything, I'm sorry to say as no one in LR has engaged on this yet. But I will try.

Given this was an experiment, I am very surprised that this worked for me as well as it did.
This tells me it's most likely not the transmission, but the software / code that controls these functions.

2017 Discovery Sport HSE
loire17 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Land Rover Discovery Sport Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome