Low battery indicator - Page 2 - Land Rover Discovery Sport Forum
User Tag List

 1Likes
Reply
 
LinkBack Thread Tools
post #11 of 17 Old 08-07-2017, 09:41 AM
Senior Member
 
4sallypat's Avatar
 
Join Date: Oct 2015
Posts: 588
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 130 Post(s)
Did your car receive a battery update software update from LR:

Q634 Gateway Module Stay Awake - Battery Drain - software configuration
?

This appears to be the culprit in having your car awaken and drain the 12V auxillary battery (the battery used for start/stop). It has nothing to do with the main 12V battery.

2016 DS HSE - 5+2 3rd Row, Climate Comfort, Driver Assistance +, Audio Upgrade, Gloss Black Roof Rails
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
4sallypat is offline  
post #12 of 17 Old 08-08-2017, 08:06 AM Thread Starter
Junior Member
 
Join Date: Mar 2017
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
(Thread Starter)
Yes i received it.
eitanv is offline  
post #13 of 17 Old 09-28-2017, 04:17 AM
Junior Member
 
Join Date: Sep 2017
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Battery placed on battery charger.

I placed my battery on charge over night. No problems since.
Bob007 is offline  
 
post #14 of 17 Old 04-02-2019, 09:44 PM
Junior Member
 
Join Date: Apr 2019
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I know this is an old thread.

Any update on this? How’s it doing now? Any more issues?

I have a 2016 Evoque with a battery warning. I’ve had the battery tested at a local shop and it tests good. Battery seems to show low on dash about 2 days after charge. Pretty annoying. And I just noticed the auto start stop doesn’t work. I don’t know when that started. Hasn’t worked in like a year I’m thinking. Some how the tire pressure said that one tire was zero psi but then it fixed on its own. Also SOS system warning popped up a few days ago but went away. Somehow tire pressure changed away from light load setting on its own so then it was alerting that the tires were all low.

I’m worried I’m going to have issues the whole time we have the car. Hoping yours still is good and I’m hoping it will take only once to fix.

I think it has already had the battery software update recall thing.

How can I find a list of all possible recalls on my car? Any links.

We are planning on taking it in to Land Rover this Saturday.
MathMan is offline  
post #15 of 17 Old 04-27-2019, 07:39 AM
Junior Member
 
Join Date: Apr 2019
Location: UK
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I would be interested to know what they say as my 2016 DiscoSport has been in twice lately for low battery etc and all they do is say the battery needs charging up because of my low mileage.
Jimbo is offline  
post #16 of 17 Old 04-29-2019, 05:46 PM
Senior Member
 
Join Date: Jul 2016
Location: Surrey B.C.
Posts: 200
Mentioned: 0 Post(s)
Tagged: 1 Thread(s)
Quoted: 27 Post(s)
Ironically on the same day my low battery warning came up as well. I do low mileage and lots of short trips as well so sort of expected. I installed a CTEX battery charger connection in the car so I can easily recharge the car again, and again.


The battery does not seem that low but it seems as Land Rover has set the threshold at an unreasonable level.
Bill F is online now  
post #17 of 17 Old 05-02-2019, 09:37 PM
lkv
Junior Member
 
Join Date: May 2019
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by eitanv View Post
Solved!
(I hope)
The central garage fixed the issue, the Low battery indicator no longer appears...
They said they had the software "reset" a few times, not sure what they meant, probably the battery "sensor" part.
After a few days of driving, and parking, the probelm did not apear again (even with my daily short trips).
Car now drives like a dream, love it again.
till next time
Glad to hear that i have a brand new Evoke less than
100 miles and mine is doing the same thing. today the radio touch screen went dead!
Called the dealer and they said it probably needs a software update.
lkv is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Land Rover Discovery Sport Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome