Satellite radio startup delay - Land Rover Discovery Sport Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 5 Old 06-12-2017, 07:05 PM Thread Starter
JEL
Junior Member
 
Join Date: May 2017
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Satellite radio startup delay

My 2016 Discovery Sport satellite radio comes on immediately but the presets and the ability to change channels is delayed. Most times it is about a minute. 2 or 3 times a week its more like 5 minutes and sometimes its over 20 minutes. I just bought this from a dealer a few weeks ago. They told me that there is a technical bulletin out by Land Rover that states there is a 15-30 second delay with the satellite radio is considered normal. I would be happy with that. I asked about a 5 - 20 minute delay. He said they want to do more research so they kept the vehicle.

Anyone else had similar issues and if so how were they resolved?

Thanks
JEL is online now  
post #2 of 5 Old 06-13-2017, 07:45 AM
Junior Member
 
MGLarry's Avatar
 
Join Date: Sep 2016
Posts: 26
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
JEL - I have always experienced a delay considered normal (15-20 seconds, less if I remotely unlock the car before I get to it, seems to get the boot-up process started before you get to the car). Have never experienced anything longer than that.

2016 DS HSE, Corris Grey w/Black Pack, Climate Comfort Pack, Driver Assist Pack, Vision Assist, Audio Upgrade, 5+2 seating, Protection Pack, Black Roof Rails
MGLarry is offline  
post #3 of 5 Old 06-13-2017, 08:21 PM Thread Starter
JEL
Junior Member
 
Join Date: May 2017
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Yes...much longer. One time over 20 minutes, until I arrived at my destination. When I got back in the vehicle it came back on fully as it should. Most times its a minute or 2. I just got it back from the dealer. They did an "audio module" update. So far so good.
JEL is online now  
 
post #4 of 5 Old 06-15-2017, 11:01 AM
Member
 
Join Date: Apr 2016
Posts: 36
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Check with your dealer to see if you have the latest software update. There was a new on a month or two back.

Mine would not only start up slow, but would reboot on its own and forget the radio preset on occasion.
Radius is offline  
post #5 of 5 Old 06-15-2017, 08:32 PM Thread Starter
JEL
Junior Member
 
Join Date: May 2017
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Since the Audio Module update on Tuesday it has been working fine. Land Rover states that there can be a 15-30 second delay on satellite startup. That is exactly what it is doing now. I can live with that.
JEL is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Land Rover Discovery Sport Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome